Want to Donate?

Project type: Android
Current version: 2.1.0
Google Play store link: https://play.google.com/store/apps/details?id=com.thibaudperso.sonycamera

This project is a proof of concept to show that it's possible to create your own application for the rx100 mk2
For more information read this thread

How to use

You just need to:

Frequently Asked Questions

Does this app work with my camera?

Does your camera have a Wifi connection? If not, this app is not compatible. Check the following list to know if your device is compatible. If your device is not on the list and has a Wifi connection, please follow the steps of this tutorial: Adding a new camera device part.

My camera is automatically set to auto-mode when I use your app. Can I set settings manually?

Sony choose to set the camera settings to auto when you use their WebService. Fortunately on some devices we can set this settings using this same connection. But for the moment, I haven't implemented this feature. List of supported cameras should be: A7R, A7, NEX-5, NEX-6, A5000, A6000, DSC-HX400, DSC-HX60.

Does your app exist for iOS?

No, but someone is working on it. You can follow this thread https://plus.google.com/100354636489488589436/posts/Y5P9pwDfXEy

Can I use your app by USB?

No, Sony only provides a support using Wifi.

When will be the next release? Can you do ... ?

I work on this app when I have free time. So I can't tell you, when will be the next release and if I will implement what you need. The code is opensource. It's up to you to add your features and share them. But you have to know Sony's SDK is very light and doesn't allow to do lots of things (as bulb, hdr...). For more information follow this link: https://developer.sony.com/develop/cameras/

This feature doesn't work with my camera, what can I do?

I'm just an indie developer, I only have a RX100 mk2 and sometimes I can test my app on a NEX5-R. For others devices, I can't really test features.

Some images are missing during timelapse

It's a known issue. On some devices (like my RX100 mk2) with a normal shutter speed, the camera need lots of time to save the picture and is not able to take a new picture. That's why I recommand to set the interval time at least to 5sec. I hope Sony will provide a new firmware to fix it.

Camera list

Working Devices

Not tested devices

Adding a new camera device

In timelapse-sony application, each Sony camera has an associated API address.
You can find current associations in the xml/devices.xml file.
If your device is not listed in this file, don't worry, maybe we can add it.

Step 1

Firstly, try with one of the 3 following devices: A5100, RX-10, RX-100 mk2, maybe one works with your camera. In this case, let me know by email what is your camera name and which device you have selected.

Step 2

If Step 1, didn't work,